DNS Host issues

Resolved
Major outage
Started over 1 year ago Lasted about 2 hours

Affected

Website
Updates
  • Resolved
    Resolved

    The issue has been fully resolved.

  • Identified
    Identified

    The issue has been resolved, DNS records may take a few hours to propagate to all users. We will continue to monitor situation, and post any other updates here.

  • Investigating
    Investigating

    One of our third party DNS providers is having issues, making our website inaccessible. We are monitoring and investigating the issue, and will update when we have more information. Next update in 30 minutes.